Server is running well but I can´t select spawn location

Discussion in 'Installation' started by MatthiasGTR, Jul 15, 2017.

  1. MatthiasGTR

    MatthiasGTR New Member

    Joined:
    Jul 15, 2017
    Messages:
    4
    Likes Received:
    0
    Hey guys!

    I hope someone of you can help me with my problem.
    The problem is that I can´t select the spawn location for my character. I just see this Desolation Redux background and I can hear some of these ambient sounds.
    I´m hosting my server currently on my own computer to test how it works. Everything went well without any errors.
    At this point I don´t know how I should resolve this problem.
    Can you help me please?

    I appreciate every help!

    Regards
    MatthiasGTR
     
    Last edited: Jul 15, 2017
  2. Warfighter

    Warfighter New Member

    Joined:
    Jul 6, 2017
    Messages:
    17
    Likes Received:
    12
    Could you make a pastebin or something of your rpt log?
     
  3. MatthiasGTR

    MatthiasGTR New Member

    Joined:
    Jul 15, 2017
    Messages:
    4
    Likes Received:
    0
    Here is an excerpt of the RPT file:

    18:26:50 "TimeManagement > Server Unlocked"
    18:26:50 Successfull attempt to execute serverCommand '#unlock' by server.
    18:26:50 "TimeManagement > INFO: restartTimer started"
    18:27:00 "ERROR: CANT KEEP UP! Thread Count: [17,0,0,1] - FPS: 8.46113"
    18:28:00 Unaccessible
    18:28:03 Error in expression <["MSG",none]>
    18:28:03 Error position: <none]>
    18:28:03 Error Undefined variable in expression: none
    18:28:03 "DB RESPONSE > NIL RETURN"
    18:28:03 Error in expression <_sendRequest;
    _playeruuid = _response select 0;
    _dpvaruuid = _response select >
    18:28:03 Error position: <select 0;
    _dpvaruuid = _response select >
    18:28:03 Error Generic error in expression
    18:28:03 File DesoDB\Serialization\Players\fn_loadPlayer.sqf, line 19
    18:29:07 "INTERNAL ERROR | FATAL > PlayerUUID or CharUUID not on the targeted unit!"
    18:29:10 Client: Remote object 3:0 not found
    18:29:10 "Desolation> Saving Disconnected Player (MatthiasGTR)"
    18:29:10 Attempt to override final function - null_callback
    18:29:10 "INTERNAL ERROR | FATAL > PlayerUUID or CharUUID not on the targeted unit!"
    18:29:11 Warning: Cleanup player - person 2:15894 not found
    18:29:13 Warning: Cleanup player - person 2:15894 not found


    I think that could be interesting because that´s the section in the RPT file where I try to spawn my character.
     
  4. Warfighter

    Warfighter New Member

    Joined:
    Jul 6, 2017
    Messages:
    17
    Likes Received:
    12
    Looks like a database connection problem (18:28:03 "DB RESPONSE > NIL RETURN")
     
  5. MatthiasGTR

    MatthiasGTR New Member

    Joined:
    Jul 15, 2017
    Messages:
    4
    Likes Received:
    0
    Ok thanks!

    I resolved it by rebuilding everything.

    Regards
    MatthiasGTR
     
  6. Warfighter

    Warfighter New Member

    Joined:
    Jul 6, 2017
    Messages:
    17
    Likes Received:
    12
  7. TitusGroan

    TitusGroan New Member

    Joined:
    Dec 27, 2016
    Messages:
    28
    Likes Received:
    24
    I followed the guide to the letter and when I log onto my server I get no spawn options (south east/east/west), then after 2:40secs "Mission Completed". I've deleted everything and redone it twice and the same issue.
     
  8. mr bullet

    mr bullet New Member

    Joined:
    Jul 18, 2017
    Messages:
    11
    Likes Received:
    1
    is it calling the mission file correctly are you seeing any sort of screen ? can you link a rpt log?
     
  9. Legodev

    Legodev Developer Staff Member

    Joined:
    Jul 18, 2016
    Messages:
    408
    Likes Received:
    144
    my dll gets blocked, find out what blocks it and unblock it
     
  10. TitusGroan

    TitusGroan New Member

    Joined:
    Dec 27, 2016
    Messages:
    28
    Likes Received:
    24

    ALL FIXED Now.
     
  11. Legodev

    Legodev Developer Staff Member

    Joined:
    Jul 18, 2016
    Messages:
    408
    Likes Received:
    144
    then tell the people how you fixed it ...

    i hate when people say all fixed, but don't explain what they did so that it might help others
     
  12. mannmitmaske

    mannmitmaske New Member

    Joined:
    Dec 14, 2017
    Messages:
    4
    Likes Received:
    0
    i hate it too :/
     
  13. frobbert

    frobbert New Member

    Joined:
    Mar 31, 2019
    Messages:
    3
    Likes Received:
    1
    Hi,
    just one thing i came accross the last days very often when testing localy aram3 server
    and deploy to remote linux box afterwards..
    Often the Addons folder uses a capital letter A - on linux this seems to be an issue as it seems to be case sensitive.
    Often renaming the Addons folder to "addons" on linux solves issues which are not that obvious when looking at the rpt log files..
    Yep and regarding those unfamiliar with libredex this is a good post: http://desolationredux.com/forums/threads/libredex-on-linux.929/

    and of course check the file permissions for the user you're starting the server with, e.g. steam. has to have execute permissions to libredex
     
    Last edited: Mar 31, 2019
  14. frobbert

    frobbert New Member

    Joined:
    Mar 31, 2019
    Messages:
    3
    Likes Received:
    1
    Hi @Legodev.
    I still have problems on my "limited" linux virtual machine where i want to install the server for test purposes.
    It seems clear that it is a problem with libredex. Although credentials are correct it cant be used to conect to the database (that is setup correctly as i can connect to it when using windows arma locally-> to remote db on that virtual linux).
    The Mariadb version is
    on
    Debian 2.6.32-042stab134.8 #1 SMP Fri Dec 7 17:16:09 MSK 2018 x86_64 GNU/Linux


    I am using the alt debug version of libredex - the logs are :

    Could you create a libredex with mariadb connection and without special cpu instructions?

    ldd linux_alt (0.3.2)
    ldd of https://cdn.discordapp.com/attachme...0/388823705314131979/libredex-201712082342.7z

    If using this version of libredex i get further...:
    But from the mysql server i can see that no connection is made
    full text

    and after a while:
     
    Last edited: Apr 1, 2019
  15. Legodev

    Legodev Developer Staff Member

    Joined:
    Jul 18, 2016
    Messages:
    408
    Likes Received:
    144
    Hey, the connection is only made, once apmsdb requests the initialization, so its not done right at the beginning. So far everything looks fine, i would need an complete version of the "LibRedExLogFile.txt" file.

    Also the version from December 2017 seems to be quite old. Where did you get the link from?

    This should be the latest version:
    https://cdn.discordapp.com/attachments/193509594889322517/433735092473430025/libredex-1.0.3.3.7z

    Edit: while reading back my gitlog, the 1.0.3.3 should work, but could be worth to compile the latest release from git yourself.
    When i get home i will bake a complete release, if i don't forget it.
     
    Last edited: Apr 1, 2019
  16. frobbert

    frobbert New Member

    Joined:
    Mar 31, 2019
    Messages:
    3
    Likes Received:
    1
    Hi, and thank you for your answer.
    Seems your new version is more talkative than the older one.
    Now I saw this
    and so changed from localhost to 127.0.0.1 as I have no mysql socket connector established (again learned sth...)

    and now working ;)
    Thank You very much for that new libredex.
     
    Last edited: Apr 1, 2019
    Legodev likes this.

Share This Page